Back to overview
Downtime

Service Downtime

Sep 23 at 09:36am EEST
Affected services
Homepage

Resolved
Sep 23 at 09:40am EEST

We’re happy to report that the issue causing downtime has been resolved, and all services are back online.

Thank you for your patience and understanding during this period. If you continue to experience any issues, please don't hesitate to contact our support team.

Created
Sep 23 at 09:36am EEST

We are currently experiencing unexpected downtime. Our team is working hard to resolve the issue as quickly as possible.