Back to overview
Degraded

Homepage Degraded

Sep 24 at 03:12pm EEST
Affected services
Homepage

Resolved
Sep 24 at 03:38pm EEST

We are pleased to inform you that the maintenance on our homepage has been successfully completed. The site is now fully operational, and all services have been restored.

Created
Sep 24 at 03:12pm EEST

We are currently experiencing degraded performance on our homepage as we conduct essential maintenance. You may notice slower load times or limited functionality during this period.