Back to overview
Downtime

Server issues

Oct 30 at 03:44pm EET
Affected services
Game Panel

Resolved
Oct 30 at 05:04pm EET

The issue has been resolved.

Updated
Oct 30 at 03:55pm EET

We have identified the cause of the recent service disruptions as an issue on the backbone affecting several of our servers. This may have caused instabilities in reaching our network and services, impacting site performance and accessibility.

As an immediate solution, we’ve rerouted traffic for our game panel to unaffected servers to ensure ongoing access. Our team is closely monitoring the situation and working with our partners to restore full stability across all services.

Thank you for your patience and understanding as we address this incident. We’ll keep you updated on any further developments.

Created
Oct 30 at 03:44pm EET

We are currently experiencing an unexpected service disruption affecting site speed and availability. Some users may find the site extremely slow, while others may be unable to access it altogether. Our team is actively investigating the issue and working diligently to restore full functionality as quickly as possible.

We apologize for any inconvenience this may cause and appreciate your patience during this time. We will keep you updated as we make progress on the resolution.