Back to overview
Maintenance

Short Maintenance on a Backend Server

Oct 17 at 11:15am EEST  –  Oct 17 at 11:42am EEST
Affected services
Homepage
Game Panel

Resolved
Oct 17 at 11:42am EEST

Maintenance has been completed.

Created
Oct 17 at 11:15am EEST

We will be doing a quick maintenance on one of our backend servers, which may lead to some features on our homepage and game panel not working properly such as Addons and Version page. This maintenance should not take longer than 30 minutes.