Back to overview
Maintenance

Planned Maintenance for SG

Mar 09 at 04:00am EET  –  Mar 09 at 04:58am EET
Affected services
Singapore, AS

Resolved
Mar 09 at 04:58am EET

Maintenance has finished.

Created
Mar 09 at 04:00am EET

We will be applying software updates to servers which require a server restart. During the maintenance window, there will be about a 5-10 minute window where game servers will be offline. All servers should come back online automatically.